News Forums RAIN General Discussion and Troubleshooting Why is my character not moving even though I followed the tutorial?


This topic contains 6 replies, has 5 voices, and was last updated by  prime 4 weeks, 1 day ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #26101


    I downloaded RAIN to look into it and when I tried to run the first tutorial (Basic Object Rigging in RAIN for Unity) I tried to set the “Move Target” attribute to a variable like it shows in the video but that drop down is not in my version.

    I put the variable name in the field labeled “Move Target” but it does not work when I press play.

    Here is my version information:
    RAIN is a component of Sentio

    Thanks for ANY help in resolving this issue.

    Try this:
    1) Parent “move” under “waypointpatrol” – leave waypointpatrol-Repeat:Never
    2) Leave move-Repeat:Never

    Note: no Parallel or Sequence is necessary yet unless you start adding other decisions and stuff.

    As for Animation, I am not sure because I am not focusing on that right now. I would assume it, too, is parented under “waypointpatrol” but might actually still be Repeat:Forever.

    These changes were made around version 2.0.9

    -Iuxeayor ;>



    Hello. I too am getting this issue. I have went through countless tutorials and have not been able to get this to work. Has anyone had any luck with this method? Not having the drop down menu is completely confusing me. But it is a necessity to use rain as there are endless possibilities with it. And quite frankly it’s better than any other system that I have found. Any help will be helpful thanks.



    Seems like a few people had problems with the prior sample and tutorial. Apologies for that.

    There’s a new sample project and tutorial available with RAIN 2.1. If you need additional help with that, feel free to contact us directly (support at rival theory dot com)



    I get the same with the latest version i follow the tutorial “Get Started With RAIN 2.0.10 Part 1: Simple Patrol ” and nothing happens it is the third time i am giving a chance to RAIN



    Are you using the 2.1.5 version of RAIN? Do you have a navmesh in your scene?

    If you are using 2.1.5 and do not have a navmesh, then make sure you check the Allow Off Graph Movement box on the AI Motor.



    I believe almost everyone is not clicking on the “navigation mesh” object in the Hierarchy and hitting “generate navigation mesh”, it happened to me countless times. Once you realise it Rain becomes alive, but it is so depressing if you dont, you end up thinking ah another load of nonsense from the asset store. But this one is worth giving a real chance.

    • This reply was modified 1 month ago by  radiant.
    • This reply was modified 1 month ago by  radiant.


    We’re adding some debug text to the Navigation Mesh inspector that will let you know when you are running a scene without having generated the mesh.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.