News Forums RAIN General Discussion and Troubleshooting Tree Binding Nodes don't seem to work

This topic contains 2 replies, has 2 voices, and was last updated by  desaro 2 years ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #5840


    Either I am missing something or the Tree Binding node isn’t working as expected. The documentation for the node states: “Binding Name - the name of the field that will appear in the BasicMind editor for AI that use the parent Behavior Tree.”

    Steps to reproduce:

    - open any behavior tree
    - add in a Tree Binding node and fill in the Binding Name, lets say “myBinding”
    - go back to any AIRig inspector and choose the BasicMind tab
    - assign the behavior tree that you just modified
    - take note that the “myBinding” field does not appear in the BasicMind tab. Screenshot:

    Expected result: the “myBinding” field should appear in the BasicMind tab with a dropdown to choose the tree to bind it to.



    Thanks for your post,

    Looks like we have a refresh issue with the editor (it only seems to update the tree bindings when the assigned tree gets changed). We’ll mark this down so we can get it fixed.

    As a temporary workaround you can remove the tree from the AI and then assign it again (or at least that worked for me).




    Looks like that worked. Just reselecting the tree got the fields to show up. Thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.