News Forums RAIN General Discussion and Troubleshooting Problem with entity (not moving with player object)


This topic contains 3 replies, has 3 voices, and was last updated by  Nevith 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #39418


    Hi guys,

    Yesterday I downloaded Rain AI and have been looking at some tutorials on youtube. After following a tutorial, I should have an AI that patrols and chases the player if the player gets detected.

    The problem that I encountered is the following:
    I’m using an first person controller script and it’s using the unity character controller (the script is from the asset store. I added an entity as a child of this player object. But when I move, the entity object does not move along with the player object. The entity object stays on the starting position of the player object while the player just moves around the scene. So what happens is: if the AI patrols and finds the entity, it moves towards the entity of the player. The ai stops moving afterwards because he is still detecting the entity. But.. the actual player object is somewhere else.

    I tried to check what happened if I made an object in another scene and adding an entity + rigidbody. In that scene, the entity does follow the player and the ai will work like it should behave.

    Anyone that can point out what I’m missing to make the entity move along with the character controller object?

    • This topic was modified 2 months, 3 weeks ago by  Kirito.
    • This topic was modified 2 months, 3 weeks ago by  Kirito.


    Sorry about the delay.

    So first check the Form field on the Entity. This should point to the GameObject you want your Entity (and associated Aspects) to follow. Assuming that is pointing to the right thing, next check the MountPoint on any Aspects you have for that Entity. If they are empty they will use the Form and should work properly, if they aren’t empty make sure they point to something on GameObject you want the Aspect to follow.

    Let me know if that doesn’t work for you.



    I’m also having this issue. If anyone can help with a fix please let me know



    After I attached it to my root bone it worked

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.