News Forums RAIN General Discussion and Troubleshooting Navmesh generation

Tagged: , ,

This topic contains 6 replies, has 3 voices, and was last updated by  prime 5 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #35115


    New to rain and my experience so far is a rather frustrating one . New issue. While in my test setup with a blank 1800×1800 terrain and a bunch of cubes as obstacles rain navmap worked well-ish(was a issue with chars floating backwards using the standard motor) .

    When i tried it in my project however it refused to generate a navmap until i had deselected my terrain layer after which it generated a “navmesh” that can best be described in this image

    here is a pic of my navmesh

    For what reasons would rain refuse to incorporate a terrain in its calculations for the navmesh.

    Also it hangs if i try make the navmesh area to large and by too large its only a 300×300 section and it just hangs my system whereas unity nav creation not only includes the terrain but also does the whole 5k area i have without any hangups. Unfortunately rain AI doesn’t work with unity navmesh though ?

    • This topic was modified 5 months, 3 weeks ago by  tawdry.


    I’ll let Sigil jump in with a specific answer. Could be an issue with the grid size, or could be some other issue specific to the terrain.



    Alright, the hanging usually means an exception was thrown while generating. You can check the console for the specific exception after canceling.

    In the case of the terrain we also try and take into account any trees on it and looking at your image I see there is an error at the bottom talking about a missing tree prefab. If any trees on your terrain are invalid the generation is probably getting stuck on them. I’m going to see about skipping those trees instead (as well as displaying a message when there are errors). In the meantime, see if removing those trees fixes the problem.

    As for the 300×300 section, that really isn’t too large for what its worth, so when it hangs see if there is an exception in the console and post it back here for us and I can help you get by what is happening.



    Hi ok the missing tree was the reason it would not include terrain in the navmesh so that fixed it . Thx

    • This reply was modified 5 months, 2 weeks ago by  tawdry.


    We recommend grabbing the latest version (2.1.8) as well. Available from our website or through our updater right now. Will hit the Asset Store in a day or two.



    Ok will do i keep pressing no on update as it warns to save whole project before proceeding a bit ominous.



    We always warn that, and we definitely recommend it. It isn’t all that hard to accidentally disconnect scripts/components on game objects, and it’s a huge pain to try to reconnect them. We work to keep that from happening, but there are a number of things we can’t control during import.

    This is our recommendation, and we follow it faithfully ourselves:
    (1) If you care about your project, put it in git, svn, or some other code repository.
    (2) Save frequently.
    (3) If you finish something in your project that you don’t want to lose, commit it right away to the repository.
    (4) You should ALWAYS make a backup before importing assets. A backup could mean commit/push to your repo, or it could mean making a copy on your drive.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.