News Forums RAIN General Discussion and Troubleshooting I can't see the GIZMOS of some Sensors some of the times

This topic contains 3 replies, has 2 voices, and was last updated by  antoineguidi 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #34098


    I bought the SQUAD asset in the UNITY STORE.
    I am working with the scene BigBattle and whenever I click on a DefSoldier or AttackSoldier or its AIRig the sensors will not draw on the Scene view.
    If I drop another instance of DefSoldier I can immediately see the sensors rendered, with this I mean the Visual Gizmos that are drawn to reflect angle, direction and range of influence of the sensors.
    I have the latest version of RAIN installed.
    Thank you.



    First off, thanks for buying the package. We appreciate it!

    I just double checked the package. By default in that scene, the AI visualizations are turned off for all the soldiers. To turn it back on, select the soldier you want to see, then notice in the AI Rig editor, to the right of the title “AI”, you will see two icons. One is a red question mark (help icon). The other is a set of shapes that is greyed out. Click the greyed out shapes and they should go back to a colored/active state. That icon turns on and off visualizations.

    Note that there are separate visualization icons on the sensors themselves. The main AI visualization toggle will override that, so both need to be on. In the BigBattle scene, the sensor visualizations are already turned on, so you just need to toggle the icon on the rig.



    Thanks for your quick response, I have turned them on, even tried changing the color of the Gizmo, yet I still can not see them.

    There is something strange, if I drop a prefab from the BigScene soldier called SoldierA, the problem persists.
    Yet if I drop the prefab DefSoldier from the Soldier folder, I have no problem.
    With the DefSoldier I can hide and show the Gizmos by using the Visualisation button.
    However with SoldierA it just does not work.

    Thank you



    It is working now.
    Must have been to close to the soldier.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.