News Forums RAIN General Discussion and Troubleshooting waypointpatrol not working

This topic contains 4 replies, has 2 voices, and was last updated by  Dave3d 1 month, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #35001


    Hello guys,

    This is my first try at RAIN. Spend al day figuring it out. Started with this tutorial: . Also read the whole wiki on waypointpatrol and tried to search for other tutorials ( many problems in comment section). Did everything step by step over and over…

    I just do a behaviour tree: root>sequencer>waypoint patrol (move target variable = nextStop)>move (movetarget = nextStop, movespeed = 1 or 2)

    Also generated the waypoint route dropped to surface and made a navigation mesh on the plane.

    I tried with different models and with the standard unity cube. I have the latest Unity free version and the latest RAIN version from the asset store.
    Tried starting a new project but no use. I am a mac user with also the latest OSX.

    Nothing is happening. The AI is just standing still and I can’t make it work. Didn’t try any other function except waypointpatrol.

    Any tips or advice? Something I am forgetting?

    Thanks in advance!

    • This topic was modified 1 month, 3 weeks ago by  Dave3d.


    Sounds frustrating - sorry about that.

    Things you might have missed:

    1) Make sure that the waypoint patrol is using quotes around the patrol route name. e.g., “Waypoint Route” instead of Waypoint Route. Make sure that your moveTarget does not. (Expressions marked with the “e” symbol require quotes around the names of things. Unquoted strings are treated as variable names.)

    2) Make sure that the AI Mind has the proper behavior tree set in it.

    3) While the project is running, and with the AI selected, open up the behavior tree editor. Are any of the lines red? If so, which?



    Thanks for the swift response! :)

    I already did exactly what you said, maybe it helps if I show the 3 images of my screens:,OQ4WVq8,UXM0F15



    It looks to me like the Move node is not a child of the Waypoint Node. Instead you have those two in parallel.

    It will probably work if you get rid of the parallel and just have two nodes - the Waypoint Route node with the Move node set as its child.



    This is a big omg moment for me. Thought I already did that a million times. I really don’t know how I got that wrong. I guess staring at it a whole day get’s you a bit narrow minded.

    It works. Much gratitude! :)

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.