News Forums RAIN General Discussion and Troubleshooting One Way Waypoint Route Not Working

This topic contains 5 replies, has 3 voices, and was last updated by  Kosta 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #40222


    My ai moves to the last waypoint and then alternates between the last point and the second to last point. He should stop at the last waypoint completely. I have it set to one way in the behavior editor. Why is it doing this.



    I too have found this to be the case.

    I upgraded a project from unity 4.6 to unity 5.3 a while ago. And a lot of things broke.

    Only now have I tried to fix all the RAIN AI and I have found that the waypoint routes no longer stop at the last point.

    I tried to get it working for hours but in the end I created a new scene with a flat plane and a cube AI with a 4 point waypoint route.

    I set the simplest AI on the cube to waypoint route “one way” “forward”.

    only to find the cube ping pong between the last two points.

    I conclude something is terribly wrong with the AI right now.

    Any chance you could let me know when this will be fixed or should I try to install an earlier version of RAIN where this isn’t broken?



    I ‘might’ have discovered the solution to this BUG.

    setting the waypoint route transform to position : 0 , 0 , 0 and rotation 0 , 0, 0 and scale 1 ,1 ,1 (ie default reset)

    seems to cure the issue of the bad ping point path finding and the like.

    I have just found this from searching the forum and the post below.

    I hope this solves the issue in my other project. (I’ll find out later today).

    Waypoint route bug 1st waypoint in middle of route

    • This reply was modified 4 months, 3 weeks ago by  theflatuniverse. Reason: forum overlay obscured post in firefox


    On a related note; I would like to know if there is a way to force the AI to go from point 1 -> 2 -> 3 -> 4

    Even if it starts nearer point 2 or 3… because right now if my character spawns near point 3 it will go there and then on to 4 rather than going to 1 first.

    • This reply was modified 4 months, 3 weeks ago by  theflatuniverse. Reason: spelling


    I take it back. This bug fix only worked on the simple cube.

    my more complex rigged characters still do not stop at the last waypoint, but instead wander around it endlessly.

    These characters have several colliders on different body parts; I’m wondering if this is confusing the AI and stopping it from realizing it needs to stop?

    Please help.



    I can confirm this issue. Thanks to theflatuniverse for the workaround.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.