News Forums RAIN General Discussion and Troubleshooting Detect and follow tree

This topic contains 3 replies, has 2 voices, and was last updated by  rbranch1 3 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #40314


    Please, without giving me a link to a tutorial that doesn’t work for me, give me a solution to a simple detect and follow procedure.

    I have successfully done it in the past, but am unable to do it now, possibly because of either RAIN or Unity’s updates.

    something like

    (i’ve tried) “sensor”
    (i’ve tried, with the ai’s tag as player, a form variable player, and the entity visual aspect of player (with the mount point on the desired game object)
    move target:player
    face target:player

    ive selected both mecanim animator and mecanim motor in the BT asset



    Your detect may be working already.So you need to know if the AI is failing to detect or failing to follow.

    When you run the game, select the AI in the Hierarchy and look at the memory tab in the rain component window. Here you will see a memory variable called whatever you put in the FormVariable on the BT Detect node. If this fails to pick up the player, the problem is the detection. Otherwise its a movement problem. Did you check Use Root Motion and Override Root Rotation in the Motor/feet icon tab?



    I checked all of that. Still not working. The ai is using mecanim animations, and ive tried every type of motor. i can see the sensor in the scene .The form variable, and mount point variables are extremely confusing and ambiguous.

    The aspect is marked corresponding to the entity. The entity is a child of the main character. The sensor is a valid visual sensor declared with the same name (Without quotes)

    Again, are there any simple solutions? I would preferably like ones that can be manipulated through code. I have countless problems with this engine.



    To add to this, I have done what you suggested. The form variable (player) does hold a value when the entity is in AI sensor range. So, it may be a move issue.

    I have tried checking ALL of the check boxes under the motor/feet icon tab. Does it have something to do with mecanim perhaps? Must I have all states listed? i’m even trying that to no avail

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.